Pierwsze Subclipse w Aptana do pracy z najnowszej wersji Subversion

głosy
34

Wersja Subclipse (1.2.4) aktualnie dostępne za pośrednictwem automatycznego Aptana w Menedżerze Wtyczki nie działa z najnowszej wersji Subversion.

Widzę na stronie internetowej Subclipse jednak, że mają one 1.4.2 out for Eclipse. Więc dodałem nową stronę zdalną aktualizację do mojego menedżera Update. Kiedy próbowałem go zainstalować, to powiedział mi potrzebne Mylyn 3.0.0 . Tak więc po wielu poszukiwaniach znalazłem Mylyn 3.0.0 i dodaje kolejny nowy zdalny serwis aktualizacji do mojego menedżera aktualizacji. Potem, kiedy próbowałem zainstalować, że to powiedział mi potrzebne org.eclipse.ui 3.3.0 lub jego odpowiednika.

Patrząc na szczegóły konfiguracji dla Aptana, wygląda na to, że jest zbudowany na Eclipse 3.2.2.

Czy ktoś wie, czy istnieje sposób, aby uaktualnić wersję Eclipse Aptana że jest zbudowany na do 3.3.0? Lub jeśli istnieje jakiś inny sposób, aby uzyskać Subclipse do pracy z bardzo najnowszej wersji Subversion?

Wiem, że to nie jest koniecznie „programowanie” pytanie, ale mam nadzieję, że jest ok, ponieważ jest to bardzo istotne z punktu widzenia doświadczenia programistycznego.

Utwórz 01/08/2008 o 14:56
źródło użytkownik
W innych językach...                            


4 odpowiedzi

głosy
16

Subclipse nie wymaga Mylyn, ale strona aktualizacja zawiera plugin, który integruje Mylyn i Subclipse. Ten jest przeznaczony dla osób, które korzystają z Mylyn. W twoim przypadku, co chcesz po prostu de-select Mylyn w oknie aktualizacji.

Subclipse wymaga również Subversion 1.5 i odpowiednią wersję JavaHL natywnych bibliotek. Pisałem na początku najczęściej zadawane pytania, aby pomóc ludziom zrozumieć JavaHL i jak je zdobyć. Zobacz: http://desktop-eclipse.open.collab.net/wiki/JavaHL

Odpowiedział 15/09/2008 o 14:26
źródło użytkownik

głosy
6

Miałem problemy z JavaHL w Eclipse Ganymede, kiedy to pracował w porządku w Eclipse Europa. Nie jestem pewien, jak Aptana jest inna, ale spróbuj albo modernizacji JavaHL lub przełączania się do realizacji SVNKit czystej java w config Subclipse.

Odpowiedział 01/08/2008 o 15:41
źródło użytkownik

głosy
4

Jeśli nie zamierzasz używać Mylyn prostu odznacz tę zależność. Nie jestem zaznajomiony z Aptana, ale w Eclipse można rozszerzyć co jest instalowane i odznacz niczego nie potrzebują.

Odpowiedział 29/08/2008 o 00:47
źródło użytkownik

głosy
3

Kiedyś url aktualizacji i zainstalowaniu adaptera JavaHL, projekt Subclipse sam i BETA adaptera SVNKit.

Po tym czasie pracował w porządku dla mnie, to jest dla platformy Linux nadzieję, że pracuje dla Ciebie.

Odpowiedział 26/08/2008 o 14:41
źródło użytkownik

Cookies help us deliver our services. By using our services, you agree to our use of cookies. Learn more